Android Mobile App Secure Device Requirement

/*image outlines*/

Issue Summary

When opening the mobile app, an error is encountered and the program cannot be opened:

  • "Cannot use this on a Insecure Device."
  • "Due to security reasons this app cannot be used on rooted devices or with Developer Options enabled."
  • "Due to security reasons this app cannot be used on rooted devices or with USB debugging enabled."

Environment/Product

  • Android 3.6.0 & up

Resolution

  1. USB debugging - an option under Developer Options, turn off USB Debugging to enable access to the mobile app.
  2. Rooted device
    1. Access to the mobile app will be denied as long as your phone has elevated access, also known as 'rooted'. 'Unroot' your device to enable access to the mobile app.
    2. Some Android models are shipped with security vulnerabilities that trigger our rooted device detection. Resolution may require that you upgrade your OS or reset to factory settings (after taking a backup). Please see this 3rd party article for more details on some devices shipped with security flaws.
  3. If none of the above apply to your device, please try contacting your device support. 

Root Cause

To maintain the highest security standards, promote the safety of our customers' data, and align with industry-wide best practices, SocialChorus has implemented a verification on the Android mobile app 3.6.0 and up to ensure that the Android phone is secure. 

Comments

0 comments

Please sign in to leave a comment.